#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(-)?([0-9]{1,3})(,)?([0-9]{1,3})?(,)?([0-9]{1,3})?(\.)([0-9]{2})"
Local $sString = "-11,252.40" & @CRLF & _
"-306.00" & @CRLF & _
"11,252.40" & @CRLF & _
"-10,946.40" & @CRLF & _
"306.00" & @CRLF & _
"-54,974.32" & @CRLF & _
"-55,356.82" & @CRLF & _
"-2,695.67" & @CRLF & _
"50.00" & @CRLF & _
"1.00" & @CRLF & _
"540,000.00" & @CRLF & _
"1,540,000.00" & @CRLF & _
"-11,540,000.00" & @CRLF & _
"-111,540,000.45" & @CRLF & _
"" & @CRLF & _
"05/02" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")