use strict;
my $str = '-11,252.40
-306.00
11,252.40
-10,946.40
306.00
-54,974.32
-55,356.82
-2,695.67
50.00
1.00
540,000.00
1,540,000.00
-11,540,000.00
-111,540,000.45
05/02
';
my $regex = qr/(-)?([0-9]{1,3})(,)?([0-9]{1,3})?(,)?([0-9]{1,3})?(\.)([0-9]{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}