import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-)?([0-9]{1,3})(,)?([0-9]{1,3})?(,)?([0-9]{1,3})?(\\.)([0-9]{2})";
final String string = "-11,252.40\n"
+ "-306.00\n"
+ "11,252.40\n"
+ "-10,946.40\n"
+ "306.00\n"
+ "-54,974.32\n"
+ "-55,356.82\n"
+ "-2,695.67\n"
+ "50.00\n"
+ "1.00\n"
+ "540,000.00\n"
+ "1,540,000.00\n"
+ "-11,540,000.00\n"
+ "-111,540,000.45\n\n"
+ "05/02\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}