re = /(-)?([0-9]{1,3})(,)?([0-9]{1,3})?(,)?([0-9]{1,3})?(\.)([0-9]{2})/m
str = '-11,252.40
-306.00
11,252.40
-10,946.40
306.00
-54,974.32
-55,356.82
-2,695.67
50.00
1.00
540,000.00
1,540,000.00
-11,540,000.00
-111,540,000.45
05/02
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end