// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(ncc|nx)\D?(\d*)").unwrap();
let string = "USS Odyssey NCC-71832 test
USS Odyssey NCC71832 test
USS Bradbury NX-72307 test
IKS Somraw test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}