package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(ncc|nx)\D?(\d*)`)
var str = `USS Odyssey NCC-71832 test
USS Odyssey NCC71832 test
USS Bradbury NX-72307 test
IKS Somraw test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}