using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ncc|nx)\D?(\d*)";
string input = @"USS Odyssey NCC-71832 test
USS Odyssey NCC71832 test
USS Bradbury NX-72307 test
IKS Somraw test";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}