#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(ncc|nx)\D?(\d*)"
Local $sString = "USS Odyssey NCC-71832 test" & @CRLF & _
"USS Odyssey NCC71832 test" & @CRLF & _
"USS Bradbury NX-72307 test" & @CRLF & _
"IKS Somraw test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")