re = /(ncc|nx)\D?(\d*)/i
str = 'USS Odyssey NCC-71832 test
USS Odyssey NCC71832 test
USS Bradbury NX-72307 test
IKS Somraw test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end