import Foundation
let pattern = #"(([0-1]\d)|(2[0-3])):[0-5]\d:[0-5]\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
23:21:55
01:13:33
55:66:23
12:44:11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)