package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([0-1]\d)|(2[0-3])):[0-5]\d:[0-5]\d`)
var str = `23:21:55
01:13:33
55:66:23
12:44:11
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}