const regex = /(([0-1]\d)|(2[0-3])):[0-5]\d:[0-5]\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([0-1]\\d)|(2[0-3])):[0-5]\\d:[0-5]\\d', 'g')
const str = `23:21:55
01:13:33
55:66:23
12:44:11
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}