$re = '/(([0-1]\d)|(2[0-3])):[0-5]\d:[0-5]\d/';
$str = '23:21:55
01:13:33
55:66:23
12:44:11
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);