// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([0-1]\d)|(2[0-3])):[0-5]\d:[0-5]\d").unwrap();
let string = "23:21:55
01:13:33
55:66:23
12:44:11
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}