re = /'(?:[^']+|'')+'/mi
str = 'Q6 contains \'foo\' && Q7 contains \'abc\''
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result