use strict;
my $str = 'Q6 contains \'foo\' && Q7 contains \'abc\'';
my $regex = qr/'(?:[^']+|'')+'/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";