$re = '/\'(?:[^\']+|\'\')+\'/mi';
$str = 'Q6 contains \'foo\' && Q7 contains \'abc\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;