# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'(?:[^']+|'')+'//gmi;t' <<< "Q6 contains 'foo' && Q7 contains 'abc'"