const regex = /'(?:[^']+|'')+'/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'(?:[^\']+|\'\')+\'', 'gmi')
const str = `Q6 contains 'foo' && Q7 contains 'abc'`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);