// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<(\s+)?img(?:.*src=["'](.*?)["'].*)\/>?"#).unwrap();
let string = "ada<img src=\"ere\" />
<img src=\"2452df\" />
<img src=\"65\" />
sd
<img src=\"ere\" />
asda";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}