package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<(\s+)?img(?:.*src=["'](.*?)["'].*)\/>?`)
var str = `ada<img src="ere" />
<img src="2452df" />
<img src="65" />
sd
<img src="ere" />
asda`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}