#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<(\s+)?img(?:.*src=["'](.*?)["'].*)\/>?"
Local $sString = "ada<img src="ere" /> " & @CRLF & _
"<img src="2452df" />" & @CRLF & _
"<img src="65" />" & @CRLF & _
"" & @CRLF & _
"sd" & @CRLF & _
"<img src="ere" />" & @CRLF & _
"" & @CRLF & _
"asda"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")