using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\s+)?img(?:.*src=[""'](.*?)[""'].*)\/>?";
string input = @"ada<img src=""ere"" />
<img src=""2452df"" />
<img src=""65"" />
sd
<img src=""ere"" />
asda";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}