$re = '/<(\s+)?img(?:.*src=["\'](.*?)["\'].*)\/>?/mi';
$str = 'ada<img src="ere" />
<img src="2452df" />
<img src="65" />
sd
<img src="ere" />
asda';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);