import Foundation
let pattern = #"(trunk) | branches\/([^\/])+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/trunk/src/it/reply/doneit/gestpay/entity/StbPaymentResultGestPay.java
http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/branches/reply_sourcing_fase2/src/it/reply/sourcing/notice/ScOtpRegistrationNotice.java
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)