#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(trunk) | branches\/([^\/])+"
Local $sString = "http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/trunk/src/it/reply/doneit/gestpay/entity/StbPaymentResultGestPay.java" & @CRLF & _
"" & @CRLF & _
"http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/branches/reply_sourcing_fase2/src/it/reply/sourcing/notice/ScOtpRegistrationNotice.java"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")