re = /(trunk) | branches\/([^\/])+/m
str = 'http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/trunk/src/it/reply/doneit/gestpay/entity/StbPaymentResultGestPay.java
http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/branches/reply_sourcing_fase2/src/it/reply/sourcing/notice/ScOtpRegistrationNotice.java'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end