use strict;
my $str = 'http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/trunk/src/it/reply/doneit/gestpay/entity/StbPaymentResultGestPay.java
http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/branches/reply_sourcing_fase2/src/it/reply/sourcing/notice/ScOtpRegistrationNotice.java';
my $regex = qr/(trunk) | branches\/([^\/])+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}