import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(trunk) | branches\\/([^\\/])+";
final String string = "http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/trunk/src/it/reply/doneit/gestpay/entity/StbPaymentResultGestPay.java\n\n"
+ "http://stb.cloud.reply.eu/svn/starbytes/starbytes_2012/branches/reply_sourcing_fase2/src/it/reply/sourcing/notice/ScOtpRegistrationNotice.java";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}