// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+\.)?(\d+\.)?(\d+)$").unwrap();
let string = "3.9.7
3.9.8
3.9.9
3.9.10
3.10.0
3.10-dev
3.10.1
3.10.2
3.11.0a6
3.11-dev";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}