const regex = /^(\d+\.)?(\d+\.)?(\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+\\.)?(\\d+\\.)?(\\d+)$', 'gm')
const str = `3.9.7
3.9.8
3.9.9
3.9.10
3.10.0
3.10-dev
3.10.1
3.10.2
3.11.0a6
3.11-dev`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}