package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.)?(\d+\.)?(\d+)$`)
var str = `3.9.7
3.9.8
3.9.9
3.9.10
3.10.0
3.10-dev
3.10.1
3.10.2
3.11.0a6
3.11-dev`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}