$re = '/^(\d+\.)?(\d+\.)?(\d+)$/m';
$str = '3.9.7
3.9.8
3.9.9
3.9.10
3.10.0
3.10-dev
3.10.1
3.10.2
3.11.0a6
3.11-dev';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);