using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+\.)?(\d+\.)?(\d+)$";
string input = @"3.9.7
3.9.8
3.9.9
3.9.10
3.10.0
3.10-dev
3.10.1
3.10.2
3.11.0a6
3.11-dev";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}