re = /^[\s\S]{6,64}$/m
str = '`1234567890-=~!@#$%^&*()_=\\`1234567890-=~!@#$%^&*()_=\\
aaaaaaaaaa
aaaaaaaaaa1
aaaaaaaaaaa1aaa1
aaaaaaaaaaa##1
aaaaaaaaaa##1aaa1
############11
^- Actually your requirement :p'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end