import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\s\\S]{6,64}$";
final String string = "`1234567890-=~!@#$%^&*()_=\\`1234567890-=~!@#$%^&*()_=\\\n"
+ "aaaaaaaaaa\n"
+ "aaaaaaaaaa1\n"
+ "aaaaaaaaaaa1aaa1\n"
+ "aaaaaaaaaaa##1\n"
+ "aaaaaaaaaa##1aaa1\n"
+ "############11\n"
+ "^- Actually your requirement :p";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}