$re = '/^[\s\S]{6,64}$/m';
$str = '`1234567890-=~!@#$%^&*()_=\\`1234567890-=~!@#$%^&*()_=\\
aaaaaaaaaa
aaaaaaaaaa1
aaaaaaaaaaa1aaa1
aaaaaaaaaaa##1
aaaaaaaaaa##1aaa1
############11
^- Actually your requirement :p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);