#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\s\S]{6,64}$"
Local $sString = "`1234567890-=~!@#$%^&*()_=\`1234567890-=~!@#$%^&*()_=\" & @CRLF & _
"aaaaaaaaaa" & @CRLF & _
"aaaaaaaaaa1" & @CRLF & _
"aaaaaaaaaaa1aaa1" & @CRLF & _
"aaaaaaaaaaa##1" & @CRLF & _
"aaaaaaaaaa##1aaa1" & @CRLF & _
"############11" & @CRLF & _
"^- Actually your requirement :p"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")