package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\s\S]{6,64}$`)
var str = `\`1234567890-=~!@#$%^&*()_=\\`1234567890-=~!@#$%^&*()_=\
aaaaaaaaaa
aaaaaaaaaa1
aaaaaaaaaaa1aaa1
aaaaaaaaaaa##1
aaaaaaaaaa##1aaa1
############11
^- Actually your requirement :p`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}