import Foundation
let pattern = #".*\/(en|nl|fr|de|es|fi|it|tr|cs|da|no|sv|pt)\/(free|gratis|generateur|kostenloser).*\-(generator|gratuit)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.voicebooking.com/en/free-voice-over-generator
https://www.voicebooking.com/nl/gratis-voice-over-generator
https://www.voicebooking.com/fr/generateur-voix-off-gratuit
https://www.voicebooking.com/de/kostenloser-voice-over-generator
https://www.voicebooking.com/es/free-voice-over-generator
https://www.voicebooking.com/fi/free-voice-over-generator
https://www.voicebooking.com/it/free-voice-over-generator
https://www.voicebooking.com/tr/free-voice-over-generator
https://www.voicebooking.com/cs/free-voice-over-generator
https://www.voicebooking.com/da/free-voice-over-generator
https://www.voicebooking.com/no/free-voice-over-generator
https://www.voicebooking.com/sv/free-voice-over-generator
https://www.voicebooking.com/pt/free-voice-over-generator
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)