use strict;
my $str = 'https://www.voicebooking.com/en/free-voice-over-generator
https://www.voicebooking.com/nl/gratis-voice-over-generator
https://www.voicebooking.com/fr/generateur-voix-off-gratuit
https://www.voicebooking.com/de/kostenloser-voice-over-generator
https://www.voicebooking.com/es/free-voice-over-generator
https://www.voicebooking.com/fi/free-voice-over-generator
https://www.voicebooking.com/it/free-voice-over-generator
https://www.voicebooking.com/tr/free-voice-over-generator
https://www.voicebooking.com/cs/free-voice-over-generator
https://www.voicebooking.com/da/free-voice-over-generator
https://www.voicebooking.com/no/free-voice-over-generator
https://www.voicebooking.com/sv/free-voice-over-generator
https://www.voicebooking.com/pt/free-voice-over-generator
';
my $regex = qr/.*\/(en|nl|fr|de|es|fi|it|tr|cs|da|no|sv|pt)\/(free|gratis|generateur|kostenloser).*\-(generator|gratuit)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}