#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\/(en|nl|fr|de|es|fi|it|tr|cs|da|no|sv|pt)\/(free|gratis|generateur|kostenloser).*\-(generator|gratuit)"
Local $sString = "https://www.voicebooking.com/en/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/nl/gratis-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/fr/generateur-voix-off-gratuit" & @CRLF & _
"https://www.voicebooking.com/de/kostenloser-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/es/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/fi/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/it/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/tr/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/cs/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/da/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/no/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/sv/free-voice-over-generator" & @CRLF & _
"https://www.voicebooking.com/pt/free-voice-over-generator" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")