# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\/(en|nl|fr|de|es|fi|it|tr|cs|da|no|sv|pt)\/(free|gratis|generateur|kostenloser).*\-(generator|gratuit)"
test_str = ("https://www.voicebooking.com/en/free-voice-over-generator\n"
"https://www.voicebooking.com/nl/gratis-voice-over-generator\n"
"https://www.voicebooking.com/fr/generateur-voix-off-gratuit\n"
"https://www.voicebooking.com/de/kostenloser-voice-over-generator\n"
"https://www.voicebooking.com/es/free-voice-over-generator\n"
"https://www.voicebooking.com/fi/free-voice-over-generator\n"
"https://www.voicebooking.com/it/free-voice-over-generator\n"
"https://www.voicebooking.com/tr/free-voice-over-generator\n"
"https://www.voicebooking.com/cs/free-voice-over-generator\n"
"https://www.voicebooking.com/da/free-voice-over-generator\n"
"https://www.voicebooking.com/no/free-voice-over-generator\n"
"https://www.voicebooking.com/sv/free-voice-over-generator\n"
"https://www.voicebooking.com/pt/free-voice-over-generator\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.