import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\/(en|nl|fr|de|es|fi|it|tr|cs|da|no|sv|pt)\\/(free|gratis|generateur|kostenloser).*\\-(generator|gratuit)";
final String string = "https://www.voicebooking.com/en/free-voice-over-generator\n"
+ "https://www.voicebooking.com/nl/gratis-voice-over-generator\n"
+ "https://www.voicebooking.com/fr/generateur-voix-off-gratuit\n"
+ "https://www.voicebooking.com/de/kostenloser-voice-over-generator\n"
+ "https://www.voicebooking.com/es/free-voice-over-generator\n"
+ "https://www.voicebooking.com/fi/free-voice-over-generator\n"
+ "https://www.voicebooking.com/it/free-voice-over-generator\n"
+ "https://www.voicebooking.com/tr/free-voice-over-generator\n"
+ "https://www.voicebooking.com/cs/free-voice-over-generator\n"
+ "https://www.voicebooking.com/da/free-voice-over-generator\n"
+ "https://www.voicebooking.com/no/free-voice-over-generator\n"
+ "https://www.voicebooking.com/sv/free-voice-over-generator\n"
+ "https://www.voicebooking.com/pt/free-voice-over-generator\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}