re = /(....)(....)(....)(....)/m
str = 'abcdefgh12345678'
subst = '$1-$2-$3-$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result