#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(....)(....)(....)(....)"
Local $sString = "abcdefgh12345678"
Local $sSubst = "$1-$2-$3-$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)