using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(....)(....)(....)(....)";
string substitution = @"$1-$2-$3-$4";
string input = @"abcdefgh12345678";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}