package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(....)(....)(....)(....)`)
var str = `abcdefgh12345678`
var substitution = "$1-$2-$3-$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}