use strict;
my $str = 'abcdefgh12345678';
my $regex = qr/(....)(....)(....)(....)/mp;
my $subst = '$1-$2-$3-$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";