// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\/[1-9][0-9]$").unwrap();
let string = "2225/35
2/25
123/12
4321/56
/22
0/00
0145/36
1234
5215
2036
256314
123456
654321
102365
123456
19
222222/12
256314/21
256314/21
06314/21
52634125/25
025636/65
025253
253641
19
01
123
032
1234
0325
123456
036254
965236
095325
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}